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1 Overview 

Canoo RIA Suite is based on the ULC technology and provides components for 

building Rich Internet Applications (RIA) in Java. Use this standard Java based library 

to develop rich, responsive graphical user interfaces (GUIs) for enterprise web 

applications within Java EE and Java SE infrastructures.  

To understand the concepts behind ULC please refer to the ULC Architecture Guide. 

For detailed information on ULC API please see ULC API documentation. The ULC 

Deployment Guide describes various modes of deploying the ULC client on the desktop 

and a ULC application on the sever. Finally, the ULC Extension Guide discusses how 

the ULC widget set can be extended. 

This document focuses on the application developer and covers the whole development 

lifecycle ranging from installation, setup, coding, debugging, and testing to deployment. 

Organization 

This document is organized into the following chapters: 

Chapter 2 helps you to get started with ULC by stepping you through a tutorial. 

Chapter3 describes how to install and set up ULC in your IDE. 

Chapter 4 describes how to develop applications using ULC. 

Chapter 5 describes features provided by add-on packages. 

Chapter 6 describes how to debug and test a ULC application. 

Chapter 7 describes how to deploy a ULC application. 

Chapter 8 describes the various ways to configure a ULC application. 

 

http://ulc.canoo.com/developerzone/ULCArchitectureGuide.pdf
http://ulc.canoo.com/developerzone/apidoc/index.html
http://ulc.canoo.com/developerzone/ULCDeploymentGuide.pdf
http://ulc.canoo.com/developerzone/ULCDeploymentGuide.pdf
http://ulc.canoo.com/developerzone/ULCExtensionGuide.pdf
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2 Getting started tutorial 

The tutorial in this chapter covers more than the traditional ñHello Worldò application. 

After completing the tutorial you will have a ready to use end-to-end application that 

manages beans in a database. 

2.1 Requirements 

You will need Eclipse to work through the tutorial. Eclipse can be downloaded from 

http://www.eclipse.org/downloads/. Please make sure that you download the package 

for Java EE developers. The tutorial cannot be executed with package for simple Java 

developers. Moreover, you will require Java JRE version 1.5 or higher. 

2.2 Install Canoo RIA Suite 

In this step you will install Canoo RIA Suite onto your computer. 

To use ULC you will first need a valid license key. There are two kinds of license keys: 

evaluation license keys and developer license keys. Evaluation license keys are valid for 

90 days and you can get one from Canoo Customer Portal 

Just register with the portal and fill in the form on the website to order evaluation key. 

Upon submitting your evaluation license key request, you will receive an email from 

Canoo that contains your evaluation license key. With this evaluation license key you 

are now ready to download and run the latest ULC installer from 

http://www.canoo.com/kurt. 

The installer will guide you through the installation steps. When you are asked to enter 

the license key, copy the text from ---START LICENSE LIST--- to ---END LICENSE 

LIST--- within the license key (that you received by mail) and paste it into the installer. 

 

 

When the installer finishes, you have installed Canoo RIA Suite on your computer. The 

installer will create the required license files in the <User Home Directory>/.ulc-

http://www.eclipse.org/downloads/
http://www.canoo.com/kurt/portalOverview/evaluationTreeView
http://www.canoo.com/kurt
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<version> directory. This directory will contain development and deployment licenses 

for ULC Core and any other extension packages whose license keys were contained in 

the pasted text. 

2.3 Generate an application skeleton 

Now that you have successfully installed Canoo RIA Suite, you are ready to generate a 

ULC application skeleton. 

Start Eclipse and configure the ULC project generator. To do so, select the Run > 

External Tools > Open External Tools Dialogé menu item. Select Ant Build  in the 

tree on the left of the external tools dialog. Click the leftmost button in the tool bar on 

top of the tree to create a new launch configuration. Enter a meaningful name for the 

new launch configuration - ULC Project Generator - and click Browse File Systemé 

to choose the <Canoo RIA Suite Install Dir>/addon/generators/build-setup.xml 

build file from your ULC installation. 

 

 

 

Select the Common tab and check the External Tools check box in the Display in 

favorites menu section of the dialog. Click Apply  to save the launch configuration and 

click Close to close the external tools dialog. The ULC project generator is now 

configured and you are ready to start it. Select the Run > External Tools > ULC 

Project Generatoré menu item to start the ULC project generator. The project 

generator opens a dialog and asks you to enter the following: 

¶ Root directory: Directory into which the generator generates the application 

skeleton. Later we will import the generated application skeleton into your 

Eclipse workspace. 

¶ Project package name: Identifies the package below which the generator 

generates all classes. 
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¶ Project name: Name which the generator uses to build Eclipse project names. 

Note that you should not have any blanks or spaces in the Project name because 

the generator uses it to generate some Java classes. 

¶ Available Extensions: Choose the extension packages you wish to use in your 

ULC application in addition to ULC Core. The generator will then include the 

required libraries for the selected packages in the build path of the generated 

projects   

¶ Generate empty project: You have the option to generate a project with or 

without the ability to generate Bean and Database related code. 

 

Click Ok to close the dialog and to generate the Eclipse projects.  

The project generator generates two projects one for the client-side code (Person-

client) and one for the server-side code (Person). Normally you will code your ULC 

application in the server-side Person project. However, in case there is a need to extend 

ULC widgets such that it requires some client-side code, then such code will have to be 

part of the Person-client project.  

The next step is to import the generated Eclipse projects into your Eclipse workspace.  
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Select the File > Importé menu item to open the import wizard. Select General > 

Existing Projects into Workspace in the tree and click Next. Enter the root directory 

you provided to the ULC project-generator in the previous step as root directory for the 

import wizard. Type tab to remove focus from the Select root directory text field. As a 

result you should now see two Eclipse projects in the Projects list, one for the ULC 

client-side code (Person-client) and one for the server-side, ULC application code 

(Person). Check both projects. Make sure that the Copy projects into workspace 

check box is not checked. Click Finish to finally import the projects into your Eclipse 

workspace. 

Have a look at the Person and Person-client projects in the workspace. The Person 

project has the skeletal ULC application com.canoo.person.PersonApplication and the 

ULC application configuration file ULCApplicationConfiguration.xml . It also has a 

class com.canoo.person.extension.ULCBlinkingButton which extends ULCButton . 

The Person-client project has the client side code for ULCBlinkingButton , namely 

com.canoo.person.extension.UIBlinkingButton. How to extend ULC is described in 

chapter 4. At this stage in the tutorial you donôt need to worry about extending ULC. 

The generated application skeleton is now part of your Eclipse workspace and is ready 

to run. Select the Run > Run History > Person menu item to run the application 

skeleton. This displays a welcome dialog that informs you that you successfully 

generated the application skeleton and that you are now ready to extend the application 

skeleton with a bean. You can learn more about this in the next section. 
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2.4 Extend application skeleton with a bean 

In this section you will extend the application skeleton with a bean. The extended 

application skeleton will allow you to create new bean instances and search for, modify 

and delete existing ones. And as a bonus everything is persisted in a database. 

First step is to define the bean in the com.canoo.person.domain package in the Person 

project. For example create the following bean in that package: 
 

package com.canoo.person.domain;  

 

import java.util.Date;  

import javax.persistence.Entity;  

import javax.persistence.GeneratedVa lue;  

import javax.persistence.Id;  

 

@Entity  

public class Person {  

 @Id 

 @GeneratedValue  

 private Long id;  

  

 private String firstName;  

 private String lastName;  

 private Date dateOfBirth;  

  

 public String getFirstName() {  

  return firstName;  

 }  

  

 public vo id setFirstName(String firstName) {  

  this.firstName = firstName;  

 }  

  

 public String getLastName() {  

  return lastName;  

 }  

  

 public void setLastName(String lastName) {  

  this.lastName = lastName;  

 }  

  

 public Date getDateOfBirth() {  

  return dateOfBirth;  

 }  

  

 public void setDateOfBirth(Date dateOfBirth) {  

  this.dateOfBirth = dateOfBirth;  

 }  

}  

 

The things that make this bean special are the javax.persistence annotations. These 

annotations are important for the persistence framework to work: 

¶ @Entity: means that the bean should be persisted. 

¶ @Id: means that this property identifies an instance, i.e. it will hold the primary key.  

¶ @GeneratedValue: means that the value of this property will be generated by the 

persistence framework. 

 

The persistence layer of the application skeleton is based on the Java Persistence API. 

We wonôt cover all aspects of the persistence framework in this tutorial. If needed, you 

can find more information about the annotations and the persistence framework in 

general at java persistence site http://java.sun.com/javaee/technologies/persistence.jsp. 

http://java.sun.com/javaee/technologies/persistence.jsp
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After defining and annotating the bean you can now generate bean views and 

persistence binding using the generator.xml Ant build script . For locating the ULC 

resources a ulc.home property is specified in the generator.properties file. This 

property may have to be adapted if the generator is used on different environments 

To create bean views and persistence bindings, Select the Run > External Tools > 

Person generate-bean-views menu item. After the bean views generator has 

terminated, you will find the following files in your project: 

 

com.canoo.person 

 PersonApplication.java 

 resources/PersonApplication.properties 

 resources/icons/* 

for the application 

the application class 

resource bundle for application class 

icons for application class 

src/ULCApplicationConfiguration.xml 

src/ULCApplicationConfiguration.xsd 

The configuration file for ULC application 

The XML schema for ULC configuration 

com.canoo.person.view 

 PersonFormModel.java 

 PersonForm.java 

 PersonDetailView.java 

 PersonMasterView.java 

 resources/PersonFormModel.properties 

 resources/PersonForm.properties 

 resources/PersonMasterView.properties 

for views 

model for form 

builder that builds a form for your bean 

detail dialog containing form 

main window part for your bean, i.e. table 

resource bundle for form model 

resource bundle for form 

resource bundle for main window part 

com.canoo.person.domain 

 Person.java 

for domain classes 

your bean 

com.canoo.person.persistence 

 PersonDAO.java 

for persistency / services 

database access for your bean 

test/com.canoo.person 

 PersonMasterViewTest.java 

for test 

a test class for the application main 

window 

src/META -INF 

 persistence.xml 

for the JPA configuration 

configuration file for the JPA based 

persistence framework 

 

To run the application, select the Run > Run History > Person menu item. The 

welcome message that we saw in the previous run has been replaced by a bean 

management application that supports all relevant operations. The main view of the 

bean management application contains a tool bar, a table, and a search field. Using the 

actions in the tool bar, you can create, modify, and delete beans. The table displays all 

existing beans and the search field at the bottom can be used to locate beans in the table.  
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The generation of the bean view and the persistence binding can be executed for any 

new bean that is added to the project. By default the already generated view and 

persistence code is not changed. To regenerate all code property 

overwriteExistingBeanViews in generator.xml must be set to true. 

If an update of the database schema is required set attribute update of task hbm2dll 

within the generator.xml Ant build scrip t to true. 

2.5 Change the Swing Look & Feel 

In this step you will improve the general look of the application. 

ULC uses a central configuration file to manage several application wide settings. One 

of these settings affects the installed Swing Look & Feel which is used to render the 

user interface. Simply change the Swing Look & Feel to improve the general look of the 

application. 

Open the ULCApplicationConfiguration.xml  file inside Eclipse. Place the caret after 

the ulc:applicationClassName element and use code completion to add a 

ulc:lookAndFeel element. Use code completion again to add an embedded 

ulc:lookAndFeelClassname element that holds the class name of a Swing Look & 

Feel, e.g. org.pushingpixels.substance.api.skin.SubstanceBusinessBlueSteelLook-

AndFeel. 

Because Substance L&F needs all-permissions to work in JNLP mode, you have to 

change this in the configuration file as well. 

The resulting configuration file should look as follows: 
 

<?xml version="1.0" encoding="UTF - 8"?>  

 <ulc:ULCApplicationConfiguration  

  xmlns:ulc="http://www.canoo.com/ulc"  

  xmlns:xsi="http://www.w3.org/2001/XMLSchema - instance"  

  xsi:schemaLocation="http://www.canoo.com/ulc ULCApplicationConfiguration.xsd ">  

 <ulc:applicationClassName>  

  com.canoo.person.PersonApplication  

 </ulc:applic ationClassName>  

 <ulc:lookAndFeel>  

  <ulc:lookAndFeelClassName>  

   org.pushingpixels.substance.api.skin.SubstanceBusinessBlueSteelLookAndFeel  

  </ulc:lookAndFeelClassName>  

 </ulc:lookAndFeel>  

 <ulc:java>  

  <ulc:forceAllPermissions />  

 </ulc:java>  

</ulc:ULC ApplicationConfiguration> 
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Select again the Run > Run History > Person menu item to start the application. With 

one simple configuration option you have dramatically changed the general look of the 

application! 

 

2.6 Change the application logo 

In this step you will change the logo displayed in the upper right corner of your 

application. 

ULC supports resource bundles to externalize resources from the source code, e.g. texts, 

icons, key strokes, etc. Resource bundles are locale aware text files containing key value 

pairs. So changing resources means changing text files instead of changing and 

compiling source code. 

Among various other things, the generated application reads the application icon from 

such a resource bundle. Open the PersonApplication.properties file inside the 

com.canoo.person.resources package in Eclipse. Search the logo.Label.icon key and 

change its value from ria_suite.png to canoo.png. 

The resource bundle file should now look as follows: 
 

Application.title=Person  

é 

logo.Label.icon=${resource.i mages.path}/ canoo . png   

é 

 

Select the Run > Run History > Person menu item to start the application and see the 

effect. 
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2.7 Change table column ordering 

In this step you will change the ordering of the table columns in the main view. 

The generator generates code that adds a table column for each property in your bean 

and orders these table columns randomly inside the table. This is the best that the 

generator can do but is usually not what you want for application. However, it is easy to 

change this generated code. 

Open the com.canoo.person.view.PersonMasterView class inside Eclipse and locate 

the configureTableBinding() method. As the method name indicates, this method is 

responsible for the configuration of the table binding. Inside this method you find one 

line of code for each table column. The order of the statements represents the order of 

the table columns in the table. As an example, delete the code line that creates the table 

column for the dateOfBirth  property and change the order of the remaining code lines 

so that the lastName table column is first and the firstName is the last one. 

The configureTableBinding() method should then look as follows: 
 

protected  void  configureTableBinding(TableBinding<Person> tableBinding) {  

    tableBinding.addColumnBindin g("lastName",  

                             getResourceMap().getString("lastName.columnHeader"));  

tableBinding.addColumnBinding("firstName",  

   getResourceMap().getString("firstName.columnHeader" ));       

    }  

 

Select the Run > Run History > Person menu item to start the application and admire 

the new table column ordering. 
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2.8 Add business logic to the tool bar 

In this step you will add a new action to the tool bar in the main view. This new action 

will invoke some business logic. 

ULCôs Application Framework uses annotated methods as actions. So first thing to do is 

to implement a method that executes your business logic. Then you annotate this 

method with the @Action annotation. The @Action annotation can take an optional 

enabledProperty argument. The value of this argument identifies a bound property 

from the annotated methodôs class that is used to enable and disable the action. As an 

example add the following method to the PersonMasterView class: 
 

@Action(enabledProperty = "selectionAvailable")  

public void  hideNames() {  

 int index = getSelectedBeanIndex();  

 if (index >= 0) {  

  Person bean = fBeanList.get(index);  

   

  char[] hiddenFirstName = new char[bean.getFirstName().length()];  

  Arrays.fill(hiddenFirstName, '*');  

  bean.setFirstName(String.valueOf(hidden FirstName));  

   

  char[] hiddenLastName = new char[bean.getLastName().length()];  

  Arrays.fill(hiddenLastName, '*');  

  bean.setLastName(String.valueOf(hiddenLastName));  

   

  fBeanList.set(index, bean);  

  PersonDAO instance = PersonDAO.getInstance();  

  inst ance.mergeElement(bean);  

 }  

}  

 

The name of this action is same as the method name, i.e. hideNames. The action can be 

executed only if the selectionAvailable property of the action methodôs class 

(PersonMasterView) is true. 

Now that you have defined the action logic, you want to add it to the tool bar. The tool 

bar actions are configured in the PersonMasterView.getToolBar() method. Add the 

hideNames action in the corresponding place. 
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public  ULCToolBar getToolBar()  {  

        return  new ToolBarFactory(getActi onMap()).createToolBar(  

                            "newAction", "modifyAction", "removeAction", "hideNames" );  

    }  

This is all you have to do to display the action in the tool bar. However, the 

corresponding button in the toolbar just displays the name of your action, i.e. 

hideNames, but no icon, no tool tip, and no mnemonic. You can change the button text 

and define other action properties in the resource bundle of the action methodôs class. In 

our case this is the PersonMasterView.properties resource bundle which can be found 

in the com.canoo.person.view.resources package. All action properties are prefixed with 

actionName.Action, which is hideNames.Action in our example. Add the following 

lines to the bundle: 

 
Title=Person  

...  

hideNames.Action.text = &H ide Names  

hideNames.Action.icon = icons/form_blue_edit.png  

hideNames.Action.shortDescription = Hides the selected person's names.  

hideNames.Action.longDescription = Hides the selected person's names. Hiding means é 

Run the application again to see the result as shown below: 

 

2.9 Change form layout 

In this step you will change the form layout in the detail dialog. 

The generator generates code that adds an input field for each property in your bean to 

the form in the detail dialog. This is the best that the generator can do but is usually not 

what you want for your application. However, it is easy to change this generated code. 

Open the com.canoo.person.view.PersonForm class inside Eclipse and locate the 

initForm()  method. As the method name indicates, this method is responsible for 

initializing the form layout. Inside this method you will find one line of code for each 

input field in the form. The order of the statements represents the order of the input 

fields in the form. With these statements you specify: 

¶ Kind of input field, e.g. text field, slider, spinner, combo box. 

¶ Configuration of the input field, e.g. width of text field, min / max values of spinner. 

¶ Layout configuration, e.g. let the input field grow or not, display a label or not. 

¶ Communication configuration, e.g. input triggers a round trip or not. 
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When having a large number of input fields, the form allows you to group them in 

several tabs. As an example, letôs place the firstName and the lastName property on 

one tab and the dateOfBirth  property on a second one. In addition letôs change the 

input field type for the dateOfBirth  property into a spinner. 

 

 

The initForm()  method should then look as follows: 
 

protected void initForm() {  

 setColumnWeights(0f, 0f, 1f);  

  

 startTab (" Names");  

 addTextField(" firstName ").columns(15);  

 addTextField(" lastName ").columns(15);  

  

 startTab (" Dates ");  

 addSpinner (" dateOfBirth ").notGrowing(false);  

}  

 

2.10 Add validation to the form 

In this step you will add validation to the form in the detail dialog. 

To add validation code, open the com.canoo.person.view.PersonFormModel class. 

This class provides all specifications for the form. Among this is the specification of 

validation on an input field. Locate the createValidators() method in this class. This 

method defines the validation to be performed for each input. Letôs add a validator that 

checks if a name field starts with a digit or not. 

The createValidators() method should then look as follows: 
 

protected IValidator[] createValidators() {  

 return new IValidator[]{new PropertyV alidator<String>(" firstName ", " lastName ") {  

  public String validateValue(String value) {  

   if (value == null || value.trim().length() == 0) {  

    return null;  

   }  

    

   char firstCharacter = value.charAt(0);  

   if (Character.isDigit(firstCharacter)) {  

    return " name field must not start with digit ";  

   }  

    

   return null;  

  }  

 }};  

}  
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2.11 Deployment 

In this step you will deploy the application on a server and access the application from 

within your browser. 

The generator that generated the Eclipse project in one of the first steps prepared 

everything for you. You get deployment capabilities for free. To deploy your 

application you need to create a WAR file and copy it to an appropriate deployment 

folder of your application server. You can export the WAR file of your application to 

the deployment directory of your application server from within Eclipse. Make sure that 

your application server supports  Java Servlet 2.4 standard.  

The generator also created a file copy-to-GoogleApp.xml and launch configuration 

Person-copy-toGoogleApp.launch that executes the XML file with Ant. It enables 

deployment of the ULC Application into Google's App Engine 

(http://code.google.com/appengine/). 

To deploy and run your ULC application as a servlet in a servlet container such as 

Tomcat, on your projectôs right-click menu select the File > Exporté menu item to 

start the export wizard. Select Web > WAR file as export destination in the tree and 

click Next >. Fill the Destination text field with the deployment directory of your 

application server (for example webapps directory of Tomcat) and click Finish to 

finally create the WAR file. You can then start your application server and direct your 

browser to the URL of your deployed ULC application as shown in the picture below: 

 

http://code.google.com/appengine/
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Alternatively, instead of explicitly exporting and deploying a war file, you can right 

click on the Person project and choose Run As > Run On Server to deploy, start 

server and bring up the application in a browser. To be able to do this you should have 

configured Eclipse to start Tomcat as a Server. 












































































































































































































